Rules using schema don,t work after upgrade to 1.3.10

Thomas shared this problem 2 months ago
Known

Hello, after firmware upgrade of my zipato to 1.3.10 my rules sceduled by Sunrise and Sunset douesn't work anymore. They have been working for ages.........

Comments (25)

photo
1

I also have a problem with sunrise and sunset, but the problem occured before I upgraded to 1.3.10.

The 9th of feb it worked (Stockholm sunset at 16:10), but from the 10th of feb, sunset actions have occured 18:17. I did not make any modifications to the rules or anything. (sunrise also occurs the wrong time since the 10th of feb).

photo
1

...but with the upgrade to 1.3.10, the sunrise/sunset does not work at all.

photo
1

It works here.. zipabox.

Try to set up a new simple rule. Just to see if that works.

photo
1

After reverting back to 1.2.41 the sunset/sunrise rules are beeing executed again, but at the wrong times, e.g. Stockholm sunset rules are executed at 18:17 instead of 16:10.

So in short:

Initial firmware: 1.2.xx.

- 9th of feb, correct sunset at 16:10

- 10th of feb, incorrect sunset at 18:17

Updating to 1.3.10.

Sunset/sunrise rules are not executed at all.

Reverting to 1.2.41

Sunset/sunrise are being executed, but at the wrong times.

photo
1

My rules are very simple and they have worked for a very long time. After upgrade to 1.3.10 they doesn't work anymore.

I have tried to create new rule using sunset and sunrise but it doesn't work either.

photo
1

Hello,


could you try making a new virtual weather station and try again?


Thank you

photo
1

Hello,

I did that. Same problem. I will do it again.

photo
1

I have tried to make a new virtual weather station but it still doesn't work.

photo
1

I found a problem that could possibly have to do with this. My virtual weather station has not been updated since 3rd of Feb, i.e. almost three weeks old data in there.

Are your wheater data updated ? (this can be seen in the Android app, or check the sunrise/sunset times).

I am currently running 1.2.41, sunrise/sunset rules are executed, but at the wrong times, the virtual weather station is for Stockholm, Sweden.

photo
1

Therše is an API call that can be used to request weather update.

You can create a rule to recurr every x hours...

https://my.zipato.com:443/zipato-web/v2/meteo/attributes/values?update=true

photo
1

In the past, it has always been updating itself, I want it to continue like that.

photo
1

make the call once and it might solve your problem. I also has long time ago problem of not updatieng anymore. I make a couple of api calls and it works since then.

photo
1

How do I do that ?

photo
photo
1

Any progress regarding this ???

photo
1

Nothing new?

photo
1

This still doesn't work for me!

photo
1

Still not working!!!

photo
1

Mine haven't worked for months, but I added new rules based on time only. And now its working! Using firmware 1.3.13 and using 433 units.72ecdb54c3381fb0c0c2ff972ee317cd127b5667b742fcfb9caab5cc3e97d867

photo
1

Mine haven't worked for months, but I added new rules based on time only. And now its working! Using firmware 1.3.13 and using 433 units.

573e4d8d7e180ec54a9c27048849d634111c80a2279a0e69795c66e78700094f

photo
1

My problem is solved, I removed the virtual weather station and added a new different one. With the new one, it works again.

photo
1

which one do you add ?

photo
1

And which one did not work ?

photo
1

The one I removed was Stockholm and then I added Tyresö.

photo
photo
1

I have this problem twice a year, when daylight saving is changing. Open your scheduler and change the settings. After saving change the settings back to what you had before and save again. In my case it works back as normal from then on. (Or change the start date, that also does the trick) This is very old bug in the software.