IKEA Zigbee "Trådfri" works with Zipato

Robert Hercz shared this thanks 4 months ago

IKEA's new range of Zigbee LED lamps seems to work fine with Zipatile. They are added, but until they are defined in the Zipato device configuration database, they will need some manual reconfiguration of types, endpoints, descriptions etc.

Given that the lamps are also available in Ikea Croatia, we can hope that they will be properly supported shortly:

http://www.ikea.com/hr/hr/catalog/products/10318263/?query=103.182.63

Germany:

http://www.ikea.com/de/de/search/?query=tr%C3%A5dfri

UK:

http://www.ikea.com/gb/en/search/?k=tr%C3%A5dfri

Norway:

http://www.ikea.com/no/no/search/?query=tr%C3%A5dfri

Comments (44)

photo
1

I would guess that wide availability of a 10 Euro controllable white lamp from Ikea would help to increase demand for also serious controllers like Zipatile!

photo
1

Agree. So Robert, you had to do some manual config change to get them working as desired? I guess still require the IP bridge (similar like Hue) as they are ZLL and not ZHA.

Can you write down a short guide how to include them? many thanks.

photo
3

@Atilla, I specifically do NOT want to have any extra bridges in my system if I can avoid it, so I threw out the Ikea bridge: I want the Zipato controller to be in direct charge of as much as possible, by itself. And here's the nice thing:

The IKEA lamps use ZigBee. To include a lamp, simply click "add device" in ControlCenter WebUI or on the Zipatile screen, and select ZipBee as "protocol". Walk over to your lamp and turn off/on 6 times (or simply screw the lamp out/in 6 times). You will see a short flicker to confirm that the lamp is doing a factory reset and making itself detectable. Shortly thereafter, the lamp is added directly to the Zipato controller - no hub or gateway involved.

BUT: Since the Ikea range of lamps are not yet in the Zipato database of officially supported devices, you need to manually find the lamp in the Device Manager, under ZigBee, tell the Zipato controller that it's a lamp, and rename the endpoints + select which you want visible in the device browser. (Note that I've had to delete and re-add a few times to get it right, but hopefully Zipato-tech will add native support for Ikea bulbs very very soon).

This effectively mean that we can change every remaining bulb in the house to these dirt cheap EUR10 Ikea E27 1000lm / 12w lamps, and control them using the Zipatile, Alexa or whatever. Unfortunately, only 400lm bulbs are available as E14 and GU11, each at EUR20,-

-I've already created several Rules in the Zipatile, which automatically turns off Ikea lamps in the wardrobe, basement and utility rooms, 12 minutes after they are switched on by the regular light switch: The rules detect state=on and start a timer. This means that I no longer need to yell at the kids for leaving the lights on, in these rooms.

photo
1

great to know, thanks Robert. As Attila mentioned though I thought they were ZLL, and although ZLL is meant to be usuable with ZHA, it isn't all the time. Phillips Hue put their own security layer on top of this which makes in un-interoperable. Go Ikea!

photo
1

News on this? .... Planning a trip to IKEA

Are the devices supported yet?

Can you adjust the color temp?

photo
photo
1

Nicklas, the bulb is cheap enough to just simply buy one and try. I have old zipatiles without zigbee so unable to test

photo
1

I 'm using one bulb (I buyed the chipest for trying 1000lumen version). the including process works, I set manually the type of device as Lamp.

zipatile is able to switch on / off the lamp but the luminosity is not managable in dasboard but using rule is possible to have access also tosetting value of luminance.

photo
1

I also bought the same this we. You just have to rename both endpoints, define it as lamps and make it visible. Then you have to try synchronize couple of times and maybe unplug/plug the bulp and after some fidling like this it should work.

However I've recognized that zigbee has quite less reach than z-wave and I dont know if devices work as repeaters. Otherwise its fine.

photo
1

Forgot to mention: You should end-up in two entries in the GUI/APP. One is a on/off switch for the bulb (true/false). The other is a dimmer (0..100%). It would be nice that 0% for the dimmer means "off", sadly this is not the case and 0% is still slightly shining. So there is still a need for a separate switch.

photo
1

how you set an entry as a dimmer? Ihavent this voice in the menu

many thanks

photo
1

I've just use "light" for both end points. The first one is on/off, the second is the dimmer function.

See picture in the following thread: rename the no-name entries and define it as "light" and make it visible.

https://community.zipato.com/topic/ikea-smart-lighting

photo
1

yes,thanks it works!!

photo
1

Now it works. On Off no second endpoint for values...

photo
1

Hallo, if you switch on the red signed endpoints reported in the previous link of Raffael you have on/off and value setting caccess

photo
1

I don't knnow how the backend works but after appr 8 hours the widget changed from Light on off to true false and the value endpoint shows a dimmer widget 0-100. I didn't change anything!? But it works! Have not tried value in rules but it works from the web and Zipatile.

photo
photo
1

Are the IKEA wireless dimmers also recognised?

Would we be able to use these as a volume control knob for audio (eg Sonos)?

That would be great!

photo
1

I presume this would work with the Zipabox with a Zigbee module? Does anyone know for certain before I go and buy the module?

photo
1

Tried it now, and atleast the on/off works on zipabox. Yet to see the dimmer work.

photo
1

Tested some more now. The dimmer function also works from zipabox. Takes 30-40 minutes to become available. I have now included three bulbs, they all work as they should. trådfri motion sensor and remotes was unsucessful. If adding to remote to bulb after joining to zipabox, zipabox lost control of the bulb. I was not able to join the remotes to the controller. Zipato have some work to do on these things, if they want to support them 100%. I would love support for the remotes beacus i think thats an area where zwave lack devices that are affordable.

photo
photo
1

I'm using 3 light with Zipatile, they work not so wel but work in rules

I would know when a light is switch on manually, up to know I'm not able to find any way to do it, so it is not possible to reconfigurate light values autmatically when it is switched manually.

any solution? or suggestion?

photo
1

As Robert wrote above:

"Since the Ikea range of lamps are not yet in the Zipato database of officially supported devices, you need to manually find the lamp in the Device Manager, under ZigBee, tell the Zipato controller that it's a lamp, and rename the endpoints + select which you want visible in the device browser. (Note that I've had to delete and re-add a few times to get it right, but hopefully Zipato-tech will add native support for Ikea bulbs very very soon)."

photo
1

yes many thanks for help, I have already done that and it works more or less..

I need a step more: I need to have the "manual switch ON" event notification accessible, or in different way I would Zipatile is able to understand when the light is switched on manually (for changing some luminosity, depending on time).

I don't know if it is possible.

photo
1

Don't follow you 100%. I don't think you can differ from manual on and automatic on. But you could sue the on state as trigger, but that of course gives the same rule if it turned on manually or automatically.

Just set the luminosity to the same regardless is my tip.

to gain manual control of light i once had a % window that the rule didn't touch. fex

when ikeaftrådfri = on

If luminosity between 0 and 85% then

set luminosity = 1%

Else

do nada

PS: I suck at programming... :(

photo
1

I have done same rule but I think ikeaftrådfri doesn't communicate its switching in ON if is turn on manualli, by wall switch, or Zipatile is not able to understand it... I don't know

instead if ikeaftrådfri is swithed OFF by software, zipatile is able to recognize the changing in ONstate.

photo
photo
1

Great products from Ikea and I hope Zipato/Zipatile soon officially supports all Trådfri products. My experiences so far:

-All lamps are recognized by Zipatile and lights can be switched on/off. However, those lamps where it is possible to change color temperature I have not yet managed to get this feature or dimming to work. Endpoints show "No attributes". Lamps with only dimming functionality seem to work and endpoints are correctly recognized.

-Motion sensor was recognized, but I am not able to get any reading from it. Endpoint shows "No attributes".

-Controller was not detected by Zipatile.

photo
6

Hi,

IKEA Trådfri Light Bulb is now officially supported on our Beta FW.

Officially release of FW will be very soon.

Zipato Team.

photo
1

Great news! How about the remote (type e1524). Inclusion process starts but is timed out.

photo
1

Super, looking forward to it. Remotes?

photo
1

C'mon guys. One step at a time... :-)

photo
1

Hi,

what is the latest beta? My Zipabox Duo is on 1.2.27.

Bulb is joined but shows offline and no intensity and temperature controls.

photo
1

My bulbs are not added that easy... Zipabox with Zigbee-module.... Can you please expand everything in your PrintScreens??

BR// Andy.

photo
photo
2

Fantastic news!

photo
1

Very, very, very nice !! A big thanks to the Zipato team.

You made my day......

photo
1

Works correctly only the lamp code: 103.182.63

Lamp code: 603.384.52 is not configured correctly

Very need to connect button code: 503.522.74

Thanks!

photo
3

Are there any plans to include the gateway and/or the remote/dimmer/sensors?

Would love to see full integration that works the same way as Philips hue.

photo
1

Also for me light bulb can only be switched on and off...no dimmer function nor color control. Empty attributes within the web gui

photo
1

Hi,

Bulbs should work now.

Can you please exclude and include bulbs again, and give me a feedback.

Best Regards,

Mario Katić

photo
2

Bulb with e27 screw base (ikea 103.182.63) works correctly

photo
photo
1

Hi.

Bulb with e14 is now correctly included but bulb goes offline.

photo
1

E14 bulb working OK

photo
photo
1

Help understand. I have a Zipabox. Do I need to buy a Zigbee module for me to be able to control the IKEA bulbs? Can I add them directly with no Zigbee module if I buy the IKEA controller?

photo
1

Hi Claus,

You need a zigbee expansion module.

https://www.zipato.com/product/zigbee-module

photo
1

Thank you for that

photo