Zipatile MQTT

Ruud Boon shared this thanks 18 months ago

Hi,

In the api I see support for adding MQTT devices. Unfortunately it doesn't work yet on the Zipatile.

I assume you are working on this, any plans when this will be released?

I would like to subscribe to mqtt events and use this in my rules, also I would like to set MQTT values.

I did connect the zipatile MQTT client to my broker. This works nicely.

Best,

Ruud

Comments (12)

photo
1

Dear Zipato team, when will full support for the MQTT protocol be implemented? Is it in the plans? If yes, then when?Thank!

photo
1

Good day.Yesterday I updated the zipatile firmware to version 1.3.44i and saw the MQTT data on my broker, I managed the devices (I was very pleased with this). But today, after rebooting Zipatile, the data ceased to flow to the broker, I tried all the options, but there was no result (data from the internal devices arrive as before). Has anyone been able to run MQTT on Zipatile? Or was it a Zipato test?133c439036d8bd19a6894908579c1e56

photo
1

Hi Dmitry

Version 1.3.44i? Sounds like you already got a new firmware available. I'm still on 1.3.13 and not showing that there is an Update.

Thanks

Beat

photo
1

This is a beta version.

photo
1

I'm running beta version but no message about an update on my system.

photo
photo
1

Oh! Do you get values on MQTT from all sensors from the Zipatile or only from internal tile sensors?

photo
1

After installing the firmware 1.3.44i, data from all sensors and virtual devices came, but after zipatile rebooted, only internal sensors came.

photo
1

ok, thanks for the update!

photo
photo
1

Guys. I jave no idea how mqtt works, i have no idea how it can be used but i have found ( after troubleshooting some things on zipatile) a menu where mqtt can be setup.

I have no idea if this makes any difference, but on the zipatile go to internal, then 3 dots on the top right corner and then mqtt

photo
1

On the zipatile that i was working in, the fields were not filled (guess this is the default) and it was turned off

photo
1

With the firmware version 1.3.6 for ZIPATILE, the MQTT protocol does not fully work (only for internal devices).Will there be development in this direction?

photo
1

I wouldn't hold your breath.

I raised a ticket to ask why it wasn't working, but the response was not very useful:

You cannot communicate directly with Zipabox. All communication is going through cloud. Same is with MQTT.

[...]

Check your network settings and if you need help with configuring MQTT please purchase https://www.zipato.com/product/professional-hour because you will need help from a developer to assist you.

So, if you want mqtt to work, they say it will only communicate outside of the LAN (which is not true for HTTP requests etc.) and to make it work they want us to spend more money.