Control HUE lights by API

acteck shared this question 6 months ago
Answered

I tried to control HUE lights directly by http command. In the CLIP API DEbugger from HUE my commands work fine. But sending them by http request they do not. Used is a "put". Does someone use this?

I found a topic some years ago where it worked. Is there any change? Is put not supported anymore?

Best Answer
photo

It does work, it actually works better than having it embedded on zipato (faster and you have group/room functionality), at least in my experience. I use it a lot, see attached, let me know if you still have questions after this.

Comments (5)

photo
1

Hi

please check the following link https://community.zipato.com/topic/phillips-hue-basic-http-control where you could find solution.

photo
1

Hey Dino,

this does not work. Tested it in different ways Everything which does work with the hue directly with its web server does not work in rules. Question is, if http-commands are executed locally or in the cloud....

photo
1

Hi

please submit a ticket with more detailed information for this particular case and our Support team will check it.

photo
1

It does work, it actually works better than having it embedded on zipato (faster and you have group/room functionality), at least in my experience. I use it a lot, see attached, let me know if you still have questions after this.

photo
1

Ok, got the error. The HUE debugger allways uses "https::...". But as Alberto wrote in his guide, use "http:....". That was my fault. I copied the debugger json 1:1 into zipato. Now it works nice. Thanks