DS18B20 And fibaro binary Sensor No temp indication

Charles Coonz shared this problem 2 years ago
Known

Greetings once more,


I recently purchased a fibaro binary sensor in order to connect with a water proof DS18B20 sensor.

I have paired the sensor properly and before that i have attached the sensor according to the instructions.

There are 3 cables on the fibaro unit and 3 on the sensor and i have attached black to blue (GND)

White to yellow (TD) and Brown to Red (TP).

When pairing i see the temperature sensor in my Device settings.

Problem is i get a 0.00C reading.

Are there any specific settings i have to configure in the Sensor configuration?

Am i missing something?

Comments (8)

photo
2

This is an update. I have submerged the sensor into a water boiler and after a few moments i got a first reading of 61.50 degrees Celcius witch seemed correct.

After that i left the boiler off and waited to cool down. After 10 minutes the temp was still stuck at 61.50 C which sounded strange.

I Then filled up the boiler with cold water and submerged again the sensor. It took around 10 to 15 minutes for a value update to 28.25 C which also seems correct.

My configuration settings are:


Interval between successive readings: 30s

Interval between forcing to send report concerning the temperature conditions: 60s

Temp Report on Value Change 1


Any idea if this is a known bug of the sensor? the readings should be much faster.

Also the default value when the sensor is paired for Temp report interval is -56s ??>

photo
1

Hi Karolos,

I have the same problem with this device. I have two DS18B20 connected, which give correct temperature values, both only every 16-17 mins (1000 sec?), no matter the settings of parameter 10, 11 and 12. I have tried different values for these parameters, both no changes in frequency of the temperature readings. Also these parameters need to be set with a value between 0 and 255, but any value above 127 returns a negative value setting (128 will return -128, 255 will return -1)????. Have you found a solution?

Regards, Emiel

photo
1

Hi Guys

i see the problem is now over 2 Years old....and i run in the same Problem.

I tried everything to get faster updates. But nothing.

A case is open!!!

Parrall i opened a case with fibaro.

For me the temp sensor is critical because it is stearing my Solar Water Pump. If the sun rises the temp inceases in 10 Minutes over 40°. Every 26min a new value is a liitle bit to slow.

Regards Chris

photo
1

With the new fibaro smart implant it works,

photo
1

Thanks for the quik answer

do you use the smart implant with an 18b20 sensor or with the fibaro combi sensor temp/humanity ?

regards Chris

photo
1

I have more than one smart implant and I using DHT22 and 18b20 sensors. You can use via smart implant up to 6x 18b20 or 1x DHT22.

photo
photo
1

I ordered some smart implant and hope that it will work.

Zipato is working on it....but you know threre is no one who can fix the problem.

From Fibaro side the case was closed: We do not have any problems withe the sensor and you are using a zipabox which is not supported. Nice Answer.

I thought that the interoperability was the master argument againts some proparitäri solutions.

But nothinks works together. This is the case nr 10 which zipato cound not solve.

Chris

photo
1

Was is a not supported zipabox?

photo
1

Correct

The Fibaro side closed the case because we are not using there home Gateway. With there gateway (fibaro home ceenter) they don´t have problems.

I read in some foren that some others have the same problem with these sensor (open hub).

It might be that we have some problems on the zipato sight. Zipato is working on it.......

regards

chris