This object is in archive! 

New rule won't trigger off HTTP sensor

Huw Pritchard shared this question 4 years ago
Need Answer

I've created a rule (see attached screenshot). What I'm looking to do is turn the lights on whenever that HTTP sensor's value goes to 'active', and off when it becomes 'inactive'.


I can control the sensor with no problems, but it's as if the rule never seems to trigger, no matter what state I set the sensor to.


So far I've tried moving the rule to the top of the stack in case anything else was triggering beforehand, rebooting the box, and synchronising several times.


I'm sure I'm doing something stupid here - anyone got any ideas?


Thanks!

Comments (8)

photo
1

There nothing seems to be wrong with the rule. Questions:

1. Have you pressed the synch button on the right not on the left? (Left does not do rules synch).

2. Have you used an existing When block from another rule? Never use existing block from another rule (or at least not the When and the Schedulers)

3. Try to debug the rule by adding a message puzzle to both if and else but with a different text. This will heps you to see if the message is never sent, or it was sent for one occasion or for both occasions.

photo
1

Hi Attila,


1. Yes - I've been using the sync button on the right hand side all along.


2. I don't think I've reused it, but to make sure, I deleted the rule and started again making sure that I didn't reuse anything.


3. I've really simplified the rule, and taken out the if block - instead, all I've got is the message puzzle block, but it still doesn't do anything. It just seems as if the rule's not being triggered at all.


a38c7cc35cfd5f6f306ff9849f56c63a

photo
1

Well, in this case I have no idea. I also have 2 HTTP sensors and they work fine. Perhaps create another sensor and try it with that. If no good, you would need to contact support.zipato.com

photo
1

Maybe your other rules are not working, try to disable all rules.

For testing, you don't need join, just add second switch

WHEN SWITCH1 IS ON

SEND MESSAGE

ACTION SWITCH2 TURN ON

photo
1

Thanks for your help Attila.


Ivica - I've tried disabling all of my rules, and then syncing my box - and that's when I realised, even with the old rules disabled they still work!


It seems as if anything I do in the rule creator isn't being synced to the box correctly, so although I've been hitting the sync button at the top right of the rule creator regularly, the box doesn't seem to have picked any of this up!


I think I'm going to log a ticket with Zipato directly - there's something weird going on here.

photo
1

Can you change status of your virtual sensor using url from state?

photo
1

Hi Ivica,


I've been able to change the virtual sensor all along.


I've actually got the new rule working now, but I noticed that whenever I hit sync, it doesn't see to work the first time round - it takes a few attempts before the rule works properly.


Weird, but at least it's working now. Thanks for your help.

photo
1

You could also try to make two rules, one for active, and second for inactive.