This object is in archive! 

Weather rule not working

Benjamin M shared this question 5 years ago
Need Answer

HI!


I want to get some information about bad weather when i leave my house.

So I created a rule that checks for bad weather but it is not working as desired.

It always runs into firtst condition (rain) although there should be no rain, but wind. Please check the screenshot.

Does anyone have an idea what is wrong or maybe some other improvements?


Thank yuo in advance.

Replies (5)

photo
1

Do you have pro feature? If yes, you can add the attribute of rain as value and then you will get idea why always the 1st if rule applies.

I also have the same 0mm rain despite it is raining and yesterday I got message that today it will rain with xmm of rainfall.

.da5a8f05af6d90f1fcfd4480fcd5711e

photo
1

Thank you for your answer. It seems to me that the values are different (the widget and the virtual weather sensor) - but i can not check the values because i have no pro features.

photo
1

Looks like it. Nothing is perfect. Probably only a weather station would solve this issue.


Also advice to change the rule so it will not stop at 1st IF or in the 1st IF there will be more info - for example, the 1st if will contain AND piece and the rain and the wind will be in there...

7ecdc5b57cef208f435e53011cc049c2

photo
1

Did you notice that the first condition should not be true but the second should be.


Also there was a hurrican yesterday (windspeed above 100 km/h) ... and the virtual weather info was about 24 km/h

photo
1

+st condition is true if the rain is more than 1mm which nowadays is highly likely. At least over here in midle europe.

Leave a Comment
 
Attach a file