Zipatile2-MQTT

Dima shared this problem 21 months ago
In Progress

Hello everybody!

Has anyone from the community tried enabling the MQTT Protocol on Zipatile2? I've been banging my head against the wall for days) I make settings similar to Zipatile1, but to no avail (data is not published to the broker). If someone was able to do this, please tell me.

Advance thanks).

Best Answer
photo

More than 6 months have passed since I opened the ticket concerning the MQTT issue on the Zipatile 2. The last notice from the support was 5 month ago. So what the hell are you doing?? Or is there no one at the help desk anymore?

It is unbelievable that there is no progress.

Replies (8)

photo
1

Looks like a zipatile 2 problem. On a zipabox i don't have a problem but i know someone who has the same problem you described. I suggest you submit a ticket.


John

photo
1

Hi John.

I opened the ticket a week ago. Dino tried to help me yesterday)) update the firmware, roll back the firmware version, update, reboot, change the broker........ etc. All standard tips), but there is no result, that's why I decided to contact the community.

p.s: On Zipatile1, MQTT works without problems (MajorDomo, HomeAssist, ioBroker.)

photo
1

Hi Dima,

The person i was talking about installed MQTTBox on a windows machine and observed there was no MQTT message coming from the Zipatile and plenty from his Openhab + Raspberry configuration.


Whe compared our MQTT config files from the Zipato - API and they were just the same.


It looks that somehow, on a zipatile, you can create a MQTT network but it simply not activated.

I am running here a Zipabox 2 with Mosquitto / Openhab / Nodered etc and have no problems whatsoever.

Must be somehow related to a Zipato 2.

John

photo
1

Thank you John, I think so too.

If you have any additional information about this issue in the near future, please send it to this topic.

photo
1

Hi Dima,

I am the one who has the same problems like you have.


I also opened a ticket. Mario, who is in this case my counterpart at the support side, told me that the developer crew has to check if MQTT is already fully implemented. Whatever that means.

The ticket was opened roughly two weeks ago but by now no progress.

Bernd

photo
1

Hi Bernd.

Let's hope that this issue will be resolved soon.

Stay in Touch)

photo
1

Still no progress.

Ticket is obviously on hold. nobody is caring as it looks.

By now the "solving period" for my problems was really short, but this time.... :-(

photo
1

Happy New Year to all!!!

Going into the New Year without MQTT))

photo
1

Two months have passed, there is no result and no one answers to the tickets. Maybe someone has at least some information about the MQTT protocol on Zipatile2?

photo
1

Hi all,

For my part with a Zipatile 2, application version 3.2.8-32800 and Version HW: 6, FW: 0X27 (39) I manage to send the information to the broker.

However, it is impossible to send commands from the broker.

The broker records the commands well but the zipatile does not seem to read them

Do you have any feedback / solutions?


thank you in advance

photo
1

Hi Adrien.

If you don't mind, publish the API settings.

photo
1

That's not on API.

It's whith the Zipatile MQTT Client.

In Applications -> Internal -> 3 Dots -> MQTT Client

photo
1

Hi Adrian.

This setting enables publishing only internal Zipatile devices to the broker. We are discussing another setting here, it publishes all the attributes of all devices connected to Zipatile (zigbee, z-wave, virtual, etc.).

photo
1

4 months have passed, and there is no result!

Thanks to Zipato for the "stability"! ;)

photo
1

Sorry, I didn't understand that ...

Maybe someone has a solution for me

photo
2

More than 6 months have passed since I opened the ticket concerning the MQTT issue on the Zipatile 2. The last notice from the support was 5 month ago. So what the hell are you doing?? Or is there no one at the help desk anymore?

It is unbelievable that there is no progress.

photo
1

Hello @Bernd!

I got tired of waiting, I switched my automation to " HA " and am very happy about it. I advise you to consider switching to "home assistant".

photo
1

Hi Dima,

switching to HA would mean to start right from scratch for the second time. More than 90 devices and about 60 rules that is not funny either. So I will wait a little more. Hope dies last.

photo
1

Hello @Bernd!

Is hope still alive? How much patience do you have?


10 months have passed since the ticket was created, but nothing happens, apparently Zipato needs a little more time to eliminate the shortcomings)) or not necessary)) or it works so well)) I'm laughing at what's going on!

photo
1

Hi!

I just replaced my Zipatile 1 with a Zipatile 2. I am able to see the same internal sensors publishing on my MQTT broker after enabling the internal MQTT sensors (adding my broker).


However i am not able to control the bell or rgb lights any longer...

photo
2

Just in case the settings have to be different for a ZipaTile 2 with v3 from a ZipaTile 1 with v2 I post my settings for a crosscheck:

7bb4a37abd5a6b496a3a217e0c7fd7f5

With these settings MQTT does NOT work ! And it is now more or less a year since Zipato is not able to solve the issue. That´s called fast as lightning ;-)

Regards

Bernd

photo
1

Hello.

More than a year ago I bought "Zipatile2" in place of "Zipatile1", but as it turned out it does not work according to the MQTT protocol, after which I opened a ticket for this problem, after contacting the support service, they promised to solve the problem in the coming days.

It's been over a year!!!!! I am shocked by your promptness. Where are you guys??? Take your product back if you are not ready to support it, return the money! How long can this be tolerated?

photo
2

I also have the same problem. From various topics my conclusion was that it should work. I have opened a ticket but no response for 3 days now. Is this a real, existing company? This is my first experience with Zipato and I'm not thrilled so far. The system was a given in a new house.

photo
photo
2

I still have my problem. I am able to switch on the internal sensors published on Mqtt. But not able to get the zipatile to react to any topics om the same broker. I was also under the impression that the zipatile2 should be able to publish topics from all signals, like the zipabox, but have not gotten that to work. On the 7th of December I got an email from them saying that they are "...waiting from our developers a fix regarding new MQTT upgrades."


I tried to ask about timeline but it has been silent since.


Not impressed with the handling of this either. At least communicate a time frame, even if it is long. Then at least I could plan how much effort I put in to it now.

photo
1

December 7th, it's funny))))) I'm expecting more than 14 months!

photo
2

I got the following answer from Mario:


"MQTT is a one way street. We are only a client who sends commands but does not accept any.

If you install firmware 2.1.24 with firmware ID 251 (in the mobile app under firmware you can post an ID) even adding MQTT network throught the webUI will work and all things will be sent to the MQTT client.

I am assuming you are using only the internal app.

Also internal app should have an update inside the App repo, please check."

photo
2

Wow and halleluja - there are signs and miracles !!!! With firmware 2.1.24 MQTT is running again on a ZipaTile 2

Great job. Not much more than a year and the issue is solved!

Thanks a lot!

photo
1

One remark to the answer of Mario:

The ZipaTile is in deed a client. But it is not true that it only sends commands. It also receives and executes commands which are via the broker addressed to the ZipaTile. In my case I can pass weather information from an openhab system to the ZipaTile into a virtual meter or set a dimmer in the Zipato system from the openhab. So at the end it is a bidirectional communication of course not directly but always via the broker.

photo
1

I can confirm, with firmware 2.1.24 (ID 251) the MQTT integration works as it supposed to be, it publishes data to the broker and it executes commands as well. It is now possible to integrate into HASS/Openhab via MQTT.

photo
1

Aron! Unfortunately execution does not work for me with the firmware 2.1.24. Do you execute commands through Zipato app or the Internal app?

photo
1

I'm not sure what do you mean "through Zipato app or the Internal app". Neither.


You need an MQTT broker, you set up the MQTT network on the Zipato webpage or via API then Zipatile2 sends all changes to these MQTT channels and subscribes to these channels which basically means in monitors them. You need an MQTT client to send the commands or some kind of smart home management application which supports it, like HASS or Openhab.

photo
1

Sorry, It was a poorly stated question so I try explain what I mean. As far as I know there are two main apps installed in the Zipatile2 tablet: Zipato (connect the tablet to cloud servers) and Internal app (collects all the sensors' data of the device - like touch event, siren, color of RGB lights etc, and publish values via MQTT).

I use only the Internal app and can successfully collect all the Internal data via HASS mosquitto broker. However, I can't figure out how to publish commands properly (like turn on siren) to the tablet via MQTT as stated in the Internal documentation: https://community.zipato.com/knowledge-base/article/internal-app-mqtt-client-documentation.

To be honest, I'm reluctant to use Zipato app as it proved to be unstable, so I stick to local control of the device

photo
2

OK, now I get it more or less.

The internal application's MQTT settings are one thing and it worked before this firmware. "Worked" means it published the sensors' data to the MQTT broker of your choice but I have no idea if you could send commands to it via these topics. Which means turning on and off the relays, starting the siren, etc. Probably it should work but who knows. Most of the people in this topic are not here for this, but for the other MQTT integration:


This is the one that was fixed in 251 and now it works. You need to create a new MQTT network on the device from the API or from the admin webpage, set the parameters there and after this Zipatile will publish every event of your connected Zwave/Zigbee devices to the broker you set up AND listens for commands. For example:

To turn off a light:

mosquitto_pub -t "/SERIAL_OF_YOUR_ZIPATILE/request/attributes/a175377b-f5de-4eb2-8396-ec2bd5a30ece/value" -m '{"value":false}'


It turns off the light AND published a message like this to a different topic (notice how /request/ is missing from it):

/SERIAL_OF_YOUR_ZIPATILE/attributes/a175377b-f5de-4eb2-8396-ec2bd5a30ece/value {"timestamp":"2022-02-25T21:56:50Z","value":true}

To get the status without turning on or off the light, which is useful because you need to define it for HASS. state_topic will be this one and command_topic will be the one with /request/:


mosquitto_pub -t "/SERIAL_OF_YOUR_ZIPATILE/request/attributes/a175377b-f5de-4eb2-8396-ec2bd5a30ece/getValue" -m ''


/SERIAL_OF_YOUR_ZIPATILE/attributes/a175377b-f5de-4eb2-8396-ec2bd5a30ece/value {"timestamp":"2022-02-25T21:56:50Z","value":true}
0a47ccf6503b2f23c3bce9b8013d0a67

The UUID after /attributes/ is the STATE attribute of my wall switch. You can find this under "Device manager" on the webpage after you click your master device then your main network, Zwave or Zigbee. You don't want the device ID or endpoint ID but this attribute ID for this specific case, turning on or off a switch. You have to dig deeper and read the documentation the find out what else can you do:

https://www.google.com/search?client=firefox-b-d&q=zippato+mqtt+pdf


Edit:

In a lot of examples the topics starts with "zipato/zipatile/" or something like this. This is totally misleading, it's base on topicPrefix and topicBase settings of the MQTT network setting of Zipatile and you don't need to set those if you don't want to. Then it start with the serial like my example. I would advise to set up the network then start listening on "#" topic (means all) so you see how it works and where to send commands.

photo
Leave a Comment
 
Attach a file