Fibaro RGBW Configuration to have 10V inputs

Alex Veldkamp shared this question 10 months ago
Need Answer

Itry different configurations but still no value in the meters.


Pleaseassist me with the right settings.

Comments (6)

photo
1

Hi Alex,


I am fighting with the same setting and saw that you have posted a more detailed overview how to configure the Fibaro RGBW controller. It had the title "A working setup with...". Unfortunately, the page somehow does not exist anymore. Could you repost, maybe in this thread or PM me the procedure and screenshots? THanks, Frank

photo
1

I don't know where the text is either.I put the text again below:

A working setup with Zipato and Fibaro RGBW device as input and output device.


After a long time of try and error I figure out how I can get a working setup.


Follow the steps below:


  • 1. Include the RGBW controller (I have change the RGWB controller name in to Aanloge input device) 1. See attach file (Step 1)
  • 2. Change the standard setting in to a input and output device
  • a. Parameter 19 from de Fibaro controller. Firs convert the binary table from Fibaro to a decimal number. See attach file (bin to dec)
  • b. Copy the decimal number
  • c. Go to the settings from the Fibaro RGBW in the Zipato web interface. See attach file (Step 2 c) and paste the number and press sent
  • d. The tricky one now the the Zipato don’t show the right number if you press on receive or if you coming later to this screen. Just ignore the number!. See attach file (Step 2 d)

E Now you go to z-wave node management and press configure node See attach file (Step 2 e) The Zipato box / zipatile knows now the you RGBW device is a input and output device and gives you the options of four input.

  • 3. Go to your device in the Zipato web interface and see the four inputs: See attach file (Step 3a and step 3b)

If you want to change the standard location (and icon) of the RGBW input controller in your Zipato app or web interface follow the next steps


  • 4. Go to the Zwave network and select the RGBW controller (I have change the RGWB controller name in to Aanloge input device) repeat the next step 4 times. Click on the edit icon. See attach file (Step 4)
  • 5. Change the Type in RGB and save. See attach file (Step 5)
  • 6. For a good refresh of the Zipato interface log out and directly log in. And see the RGB icon and your four inputs. See attach file (Step 6)

To show you that the device is working. See attach file (Step 6 and step 7)


Have fun with it and please give a sort response on this topic.

photo
1

Thanks a lot! Any chance you could pm me the screen shots? I have trouble getting the value to show percentages.

photo
1

What do you mean with the percentage not correct? In my post are two screenshots of percentage (step 6 and 7)

photo
1

It didn’t configure in percentages with me. I just see a number with two decimals for input 1.


However, I managed to develop a work around with a virtual meter (knowing that ‘dry’ corresponded to value 36 and ‘wet’ to 50).


Digging out some school math and a rule that translates 36 to 0% soil humidity and 50 to 100% did the trick.


I am now testing in a life environment to see how sun, irrigation and rain influence the values.

photo
1

Alex, thanks for the procedure.However, I'm already stuck at step 2: change setting to input/output device.

I can't seem to find that setting.My moisture meter gives me results but the number are not real clear to me. So I hoped that your primary setting might make a difference or at least allow me to follow your screen shots and procedure.

All info you could send me would me more than welcome. It can be in Dutch if you like.Thanks in advance.

photo
photo
1

I think that's the way forward. I still have problems with variable these spontaneously lose their value and are then back to 0. one of these days I'm converting my setup to virtual meters. I can read it out and make a new decision. I also use virtual meters to check the threshold, for example, spraying is needed. The lower meter is the threshold. See image .

Would you like to share your calculation so others can learn or use it?

photo
2

Hi Alex. Glad to share! So here is what I did:

a. Connect a vegetronix VH400 with a Fibaro 441 (I used IN1): there is a description here for the wiring only (in German unfortunately): https://www.siio.de/bodenfeuchtigkeit-mit-dem-z-wave-fibaro-rgbw-controller-messen/

b. Add Fibaro 441 to Zipato

c. Follow the steps 1-6 set out in Alex's post above: you should now have a multilevel switch. For me I get decimal numbers for IN1.

d. Add a virtual meter and for value 1 use the unit % (see screenshot)

e. Take your Vegetronix probe and put it in a glass of water (100% humidity). Note the value (for me it was 51). Now take the probe out and dry it well (0% humidity). Note the value (for me it was 36).

f. The math part. I assume we have a linear relationship. The formular is y=(dy/dx)*x + a. The gradient is: dy=100 and dx=15: 100/15. We have two points for x,y: (0,36) and (100,51). One point is enough to determine the value for a: 0 = (100/15)*36 + a. This gives a value for a of -240. Now we have the formula for the linear slope, which is: y = (100/15)*x -240

g. back to Zipato rules: see screen shot with the formula. basically it triggers whenever there is a change in the value for IN1. I limit the value for IN1 in the IF part to be between 36 and 52 (a tad higher than the max level of 51 I found out) - like this I don't get crazy values in my virtual meter. When the value is in this bracket, then the above formula calculates value 1 (%) of my virtual meter

I am adding also a screen shot the result.

Works fine so far. I still need to understand what the limit value is for my soil humidity when I need to trigger the irrigation in the morning (e.g. when the soil gets too dry).

photo
1

Hi, Frank,


Thank you for your explanation. I have a similar description in Dutch see link:

https://www.robbshop.nl/domotica/projecten/je-tuin-in-topconditie


For the Hexadecimal Decimal Binary Octal Converter i use see link:

http://calc.50x.eu/


I have tested with different supply voltage 12V to 20V . There were no differences in maximum value 51%. Maximum value Vegetronix probe is 20V.

Assume that everyone will now get the set-up working with this explanation.

photo
1

Your article is very meaningful, the content is quite interesting and impressive, I hope in the near future you will have many interesting and meaningful articles to bring to readers.

fnafworld