Fibaro "The Button"

Jochen Klumpp shared this question 3 years ago
Need Answer

Dear all


Has anybody made experience with Fibaro's "The Button"? I liked the very simple Idea and bought one. As usual with Fibaro devices, it took me a while to get it included.

Now it is correctly shown as "touch input" in the device manger of the Control Center. I can also select actions for holding, releasing the button and pressing it one to six times.

Very nice. In theory...

I configured simple actions (light on / off) for the one button press and twice button press events. And it worked.

Put the thing aside for an hour or so. Shows up red in the Control Center, offline.

Press it once. Light goes on. Fine.

Next day, same red mark. No action on any of the button press events. Since then, I have to wake it up, before it does anything.


Any ideas?

Comments (20)

photo
1

Jochen,


I just bought two of those babies, but haven't received yet, I will play with them as soon as I get them. I think this is a problem of distance between the button and the controller.


Every device (unless is a frequent listener device, which are usually only non-battery powered devices) have a wake up interval time. If the controller does not receive the "wake up" signal from the device once, then it puts a yellow dot on it, if it doesn't receive another one then it gets the red dot which means it is "offline" this suggests that your button is too far from the processor (and other routing nodes) or there are too many walls and stuff between them so they cannot communicate.


Try to perform a network heal (on device manager under z-wave settings) and make sure to "Wake up" when it gets the turn of any device in the same room (including your button). This will allow the controller to update the routing table and maybe if the button cannot communicate directly to the controller, it can do it through other devices.


If this doesn't work then i'm afraid you will have to find another place (Closer to the controller) to your button.

photo
1

Thank you for the advice. My first thought was also a range issue. But even in very close proximity to the Zipabox, the red mark appears after a time. Also, the button was close to a permanently powered Z-Wave device and this did also not help. I will keep on experimenting. Currently, I made the mistake of deleting it for another inclusion. Not it does not react on any button press sequence I make.

Had similar issues with other Fibaro devices. They seem to be a bit tricky to handle...

photo
1

Jochen,

Try the the network heal, when we include he devices, usually very close to the processor, both the processor and the devices keep "thinking" they are in direct comm range, and usually whe put them in a different device. Even if you had a repeater closeby, unless you perform the network heal, the button will keep trying to comunicate directly to the controller and the repeater will never find out he's got a new neighbour. If this doesn't check the wake up interval setting on the button, if everything looks good, open a ticket on zipato support. It is not normal to be offline while in direct comm range of the controller.

photo
1

It is not a range problem. Mine is going red too after a day of non use, have to wake it up pressing 4x. Rather annoying, I like the flic button more but that one is working a bit different. Flic needs to be connected to an Android or iOS device and can control Zipato through http commands. This means it will also work when you are not near your Z-Wave network, like in your car.

I understand that battery powered devices need to sleep, but why doesn't the Fibaro Button wake up from the first press? I also have a Nodon remote, that one also sleeps but no need to wake it up before sending a command.

The Button would be a nice product if it worked better with Zipato controllers.

photo
1

We will check the issue with this device and if there is a problem with the controller, we will fix it immediately next week.

photo
1

I have read the manual, it says that by default "wake up" interval is disabled, it does not says which parameter number is, only that is an advanced parameter. If this is true, this is the reason why zipabox/zipatile thinks it is offline after a day. We can change this so at least once a day it will send "wake up" command and should solve the problem. Take a look at yours settings under device manager / z wave / fibaro button to see your parameter configuration.

photo
1

Mine has a wakeup interval of 5 min so that doesn't really help.

photo
photo
1

I had the same problem. After fiddling arround with the wakeup interval, the red dot was gone.


5ee64994b649ca3ad1798b06dd99682c

photo
1

I'll try that right away. Why did you set such a high number of 600 mins? The default after adding is 5 mins.

I also had deleted the device and tried another inclusion. That was a very bad idea. I literally had to repeat the inclusion 12 times, click the button several hundred times and reset it five times to finally be included. Absolutely not awsome...

And even then, secure inclusion failed...

photo
1

When I looked at the Fibaro documentation I noticed that they use seconds and not minutes.


Wake up interval

Available settings: 0 or 3600-64800 (in seconds, 1h - 18h)

Default setting: 0

http://manuals.fibaro.com/content/manuals/en/FGPB-101/FGPB-101-EN-T-v1.1.pdf

In the zipabox they stated minutes.

So I figured that I had to divide the value by 60 in order to work and hoped that zipato converted the minutes to seconds in order for the wakeup to work.


I to had difficulties adding the button to my zipabox. After several attempts it didn't work. I waited a few days and tried again and finally after 2-3 attempts I could include it. Now it works but not everywhere. In my bedroom and half a meter from a z-wave wall switch it dosn.t work most of the time. At the other wall and 1 meter from another z-wave switch it do work. Strang no?

photo
2

I had also difficulties with inclusion of other Fibaro devices seems to be brand-related

photo
1

Well I finally got to play with my two fibaro buttons. I excluded and included both without a single issue, to be honest the only problem I have had including/excluding Fibaro devices was with one defective door sensor, other than that they have always worked for me in that matter.


After trying to include them in the rules I noticed my zipabox wasn't crated any touch sensor/control, but two generic sensors and couldn't add them into rules since there was no button's event selectable. I opened a ticket and they told me there was a typo on the descriptor and should be fixed now, I cannot try at this moment but will do when I get back home, let you guys know.

photo
1

Looks like after a bit playing with my fibaro button I am having one issue. There is no red dot in the button, it is always online but every time I need to wake it up (6 pushes) in order to send other events to the controller, after I wake it up it sends all the events for a while, but next day, same issue. I think this is on fibaro side, looks like the device itself goes into a "Sleep" Mode or something.

photo
1

Same here. But even the wake up doesn't need to be 6x. I use the long (held) push to put all the lights out before going to sleep, and this doesn't work from the first try. But if I push once (in my case this makes just a beep) and then the long push it works. Indeed the device seems to go in some kind of sleep mode.

photo
1

The Button has a wakeup interval setting, while I dont have a button to test myself, in the fibaro manual it says to go to the advanced settings tab. As there is no actual parameter mention in the manual, I guess this will need to be implemented by Zipato somehow.


See here page 9 http://manuals.fibaro.com/content/manuals/en/FGPB-101/FGPB-101-EN-T-v1.0.pdf

photo
1

The wakeup interval can be set in the settings of the Button, BTW it is the only setting available. Mine is set to 5 minutes, I guess less will drain the battery too much. But even set at 5 min there is a red dot next to it in the device explorer.

Guess it is just bad design, my Nodon remote works great without falling asleep.

photo
photo
1

Same problem here...is there a solution for this? Has someone contacted the support about this?


Thanks

Beat

photo
1

I wonder if this is an issue with Fibaro controllers

photo
1

That would be good to know! Maybe we'll have to look at a Fibaro forum to see if this issue also exists using a Fibaro controller.

photo
1

checking the forums, it seems it is. Fibaro users are having issues with it either not working, range problems, or taking a while to do anything. A lot of users saying the just dont work though. Big quality issues by the sound of it

photo
1

I guess this also might have something to do with the Fibaro only devices - Adrian, you surely know Fibaro has option for "Wake up dead nodes"...I can imagine this device works like a charm if you have Fibaro controller...

photo
1

not according to the forums. But yes the Fibaro controllers operate a lot differently.

photo
photo
1

Do you guys have any update on this issue?

photo
1

I have The Button since last week, and it works more or less like it should. Whenever I press it once, the light goes on. Sometimes it seems that he doesnt recognize the first press, but the second press always turns on the light. I never have to press it 4x to wake it up.

photo
1

In case you need some pictures of my setting: http://imgur.com/a/3nYpq

photo
1

I use a long press to give a command to dim all the lights, most of the time it doesn't work unless I push the Button once and then do a long press. It's seems to fall asleep after a while but usually I don't need to wake it using 4x, once does the job?!?

photo
1

According to the manual, wake up is 6+ presses, but also noticed a long press wakes up the device (which doesn't seem to be a "zwave wake up" rather looks more like a "device wake up"). This device seems to act very weird I see different behaviors with different user, the only thing that its common is the fact that it somehow goes into a hibernation status after some time...

photo
1

Somtimes yes, sometimes not. Today, when I came home from work (button hasnt been touched since one day), first press turns on the light.

photo
photo
1

Anyone has an update on this bug?

photo
1

(deleted)

photo
photo
2

I have the same Problem and had opened a case with fibaro.


Fíbaro had answered to my case.

It seems that we have a Problem on the fibaro sight.

But i´m not sure if these action realy helps.

Does anyone have some experinces with this method ?

Here is the answer from Fibaro.


Dear Sir:

This issue iscaused by detachment of negative band strip that closes circuit of electronicboard. We’ve managed to improve this feature and if you wish we can solve thisfor you.You need to send usthis device. Warranty procedure is described in the document https://fibaro.com/files/FIBARO_Guarantee.pdf.


Edit

photo
1

Christoph,

Did you get your fibaro button replaced? I have two with that problem...

photo
1

Hi Alberto


my Dealer had send me a new buttom. And indeed it works. The buttoms are at the same place and the new one works and the old one has the discussed problems.


regards


Chris

photo
1

Hi


i have some new Informations about the button.


In the first days it seems that the "new" button works.


But after a while only the first Press or Hold Information works.


The actors in the neighborhood are 3-5 Meters away. I can see them in the Neighor Nodes List in the Zipabox.


But if i go a little bit nearer to one of the neighbors 1-2 Meters...it works.


O.k. that must be a batterie Problem...i changed the Batterie. No Batterie Problem!!!


This is a nightmare with these buttons.


i hope i can order one which works.


regards


Chris

photo
photo
1

I am trying to get my new «button» to do a simple thing like open and close me garagedoor (Zwave)As I understand i have to make a rule in the rulecreator. I am trying but nothing is happening... any advice? I guess the rule will be simple?

photo
1

Please show us a screenshot of the rule.

photo
1

Here is the rule.... i guess I am doing something wrong because I cant get the button to do anything...not just open the garagedoor... I dont have to do anything else than creating rules after I have added the button to the zipatil/zipabox?

photo
1

The rule is ok. I think the problem is the fibaro button. Please try it with an another device.

photo