Hourly and Minutely repeat option do not work

Hako74 shared this problem 8 years ago
Solved

I tested this using the scheduler with repeat options to send a message (Pushover) to my iPhone. I had set the repeat option to minutely (every 15 minutes) and in another test to hourly (every hour).


The message was delivered once at the time I had set as the initial start date/time. The message was not send again according to the repeat settings.

Comments (18)

photo
2

Your switch should go in "sensor" puzzle.

Now there will be "On", "Off" and "Any" attributes.

photo
1

Can anyone comment on the last question. Running a rule every 15 minutes or every hour? How is that done?

photo
1

Yes, How often the rules are executed ? Because i create the rules with On/Off Switch 20 Minutes are passed and the rule is not executed.

photo
1

Hello,


I would like also to have the ability to perform an action every x hour.


Thanks

Nicolas

photo
1

The minutely setting does occur the next day at the initial time I set in the schedule. Looks like the minutely repeat option acts as the daily repeat option.

photo
2

Nice minutely repeats!


Zipato: what I think is needed for this to be even better. Is a start and stop time for the minutely repeater.


So you can set it to:

From 07:00 to 09:00 repeat every 5 minutes on Monday-Friday


Ofcourse you can check that inside the rule with puzzle-logic, But if you can set a span for the repeater it will not be a trigging at all that risk to slow down the system and also simpler to setup without extra logic in the rule.

photo
1

I have tried but the function doesn't work for me .... it launch one time and after stop :(

photo
1

ok good to know. I'm considering the "wait" option in infinite loop otherwise.

Anyway it makes sense to me only when we'll be able to have attributes in http request.

photo
1

have the same issue, want to set a 5 minute HTTP sensor refresh (calling an HTTP script) but it doen't repeat at all. Dir Zipato, could fix this please ?


thanks

photo
1

same problem for me :(

photo
1

In fact every x minutes means every day at the time set in the first screen (I have just received may daily notification )

photo
1

so that mean that it doesn't work as it should

photo
1

Hourly and Minutely repeat are now fixed. If you have existing rules with Hourly and Minutely scheduler and it didn't start to work automatically then you should sync your Rules or recreate scheduler.

photo
1

Hello,


I went on my.zipato.com and didn't see any firmware update for the fix. Has it been deployed?

photo
1

Tranquilste:

I am rather sure this is no firmware update... It is just an update on the server side of ZipaBox!


what they update is the software on server side that generate the code for your Rules, that code is then synced to your ZipaBox to be executed localy!


I can be wrong, But I don't think this is a firmware issue.

photo
1

HB is right. It's server side software update you don't need new firmware for this.

Please note that existing Hourly and Minutely schedulers will work only if you save them again (just open it to edit and save).

photo
1

Nenad: Is all code for the Rules synced to the box, or do you have some part as library code that is part of the firmware?


It is intresting to know and will give a better understanding how it works...

Library code in the firmware gives faster rule sync, But I don't think that speed is a problem.

The smaller the firmware is, the better I think, then you can easely do hotfixes without any firmware update.

photo
1

This is a old thread, but I'm having exactly the same problem with one of my rules (and I've only had the Zipabox for a couple of months). It's set to run every 30 minutes, but it only runs once a day, at the time set in the first configuration page. The repeat setting is ignored. In another two rules, they're set to run every minutes, but only run once per hour(!)