This object is in archive! 

My Schedule doesent work

Finn shared this question 2 years ago
Answered

Something wrong for my Rule with Schedule my thermostat?

It doesn't continue to set the temperature - only in that moment I activate it. For example at 22:30 it doesn't go to 17° unless I switch Of the rule and then On again. So if I manually switch Off an On 2 times a day it finds the right temperature.

How to set it for automatically changing temperature?


All the "Send message" is only for my self, trying to find the error. I try to set 2 different scenes - weekdays and weekends.

Best Answer
photo

Dont put a SCHEDULER in an IF block.

I would make two rules. One for weekdays, and one for the weekend. You can even make four rules, if you want the rules to be simple. See below:

Rule 1:


  1. WHEN {SCHEDULER weekdays 16:00}
  2. danfoss SET TEMP to 20

Rule 2:


  1. WHEN {SCHEDULER weekdays 22:30}
  2. danfoss SET TEMP to 17

Rule 3:


  1. WHEN {SCHEDULER weekend 9:00}
  2. danfoss SET TEMP to 21

Rule 4:


  1. WHEN {SCHEDULER weekend 23:00}
  2. danfoss SET TEMP to 18


If you want only two rules, this could be an example (there are more ways to do it):


  1. WHEN ({SCHEDULER weekdays 16:00} OR {SCHEDULER weekdays 22:30})
  2. IF { TIME NOW BETWEEN 15:00 AND 17:00}
  3. danfoss SET TEMP to 20
  4. ELSE
  5. danfoss SET TEMP to 17


Please note that your Danfoss thermostat has a wake-up intervall. So it might take some time for the new temp to be submitted (up to 29 minutes if your wake-up intervall is 30 minutes).

Comments (2)

photo
1

You need 2 if and no else i think

photo
1

Sorry I don't get how to do it with 2 IF. I need 4 settings as I see it. 2 for weekdays and 2 for weekends.


Can you try to explain a little more pedagogically for a beginner :-)

photo
1

The IF/ELSE block of your scheduler configure must be deleted and replace it with 2 IF block

photo
1

Hi titof174. OK know what you mean. I will try it sometime, maybe I can use it in another situation. But for now it works with the example Jan had come with. But thanks...

photo
photo
1

Dont put a SCHEDULER in an IF block.

I would make two rules. One for weekdays, and one for the weekend. You can even make four rules, if you want the rules to be simple. See below:

Rule 1:


  1. WHEN {SCHEDULER weekdays 16:00}
  2. danfoss SET TEMP to 20

Rule 2:


  1. WHEN {SCHEDULER weekdays 22:30}
  2. danfoss SET TEMP to 17

Rule 3:


  1. WHEN {SCHEDULER weekend 9:00}
  2. danfoss SET TEMP to 21

Rule 4:


  1. WHEN {SCHEDULER weekend 23:00}
  2. danfoss SET TEMP to 18


If you want only two rules, this could be an example (there are more ways to do it):


  1. WHEN ({SCHEDULER weekdays 16:00} OR {SCHEDULER weekdays 22:30})
  2. IF { TIME NOW BETWEEN 15:00 AND 17:00}
  3. danfoss SET TEMP to 20
  4. ELSE
  5. danfoss SET TEMP to 17


Please note that your Danfoss thermostat has a wake-up intervall. So it might take some time for the new temp to be submitted (up to 29 minutes if your wake-up intervall is 30 minutes).

photo
2

Thanks - now I know that Scheduler and IF block is no go. It works for me now, with the last example you suggested.

photo