This object is in archive! 

Scheduler off by 2 hours

Erik S. shared this problem 4 years ago
Solved

Hi,


I'm having problems using the scheduler. When I configure a rule to send a message at 21:00, it will be sent at 23:00, 2 hours later than specified. I'm in Norway, GMT+1. In addition, it's summertime, which is +2 hours of GMT.


All logs and events in the ZipaBox is in correct local time. The only problem I have found is that the time zone settings in the ZipaBox does not persist after I click save. Anyways, I don't see this as a problem because all other timestamps in the ZipaBox is correct.


Does anyone know what the problem might be?


Screenshot of the rule is attached.


Regards,

Erik

Comments (13)

photo
1

Zipato support has verified that it's a problem with my box. It might be related to not beeing able to save the timezone setting.


I'll update this forum post later.

photo
1

i have the same problem in the same time zone (sweden). was it a hardware problem?

photo
1

I don't know yet. The Zipato Support team has reported the bug to the developers. I'll update this post as soon as I get more information.

photo
2

I have a similar problem, my scheduled rules has changed the time when to execute by 2 hours.

The Iphone app also have wrong timestamp by 2 hours.

photo
1

Now I have the same problem when I reschedule the scheduler. Also I noticed that the indicated time of the last synchronisation is sometimes off by 2 hours.

photo
1

Same problem for me, really annoying!

photo
1

I also experience +2 hours schedule difference. If I set the schedule to 19:30, strangely another day it is 17:30...I wonder if this issue also affects the virtual weather station as it is also always synced with 2-3 hours later...

photo
1

Same for me, sunset/sunrise based rules are 2h too late, excepted on october the 5th when it was ok.

photo
1

Again & again.

I have the same problem again this morning with the scheduler ( -2 hours). Also I noticed that the indicated time of the last synchronisation is sometimes off by 2 hours (+2 hours). Obviously this is the internal time of the controller?? Therefore sunrise action were done 2 hours before sunrise.


After synchronisation the internal time was right again (last sync). However the schedulers in the rules show other times as I have originally set (-2hours).

photo
1

For me its "only" 1h wrong.

photo
1

Zipato has reported that this bug has been resolved. The problem was related to time zone settings not being saved in main settings of the box.


I had to recreate the rules using the scheduler to make this work after the fix. Old rules created before Zipato implemented the fix was still stuck at incorrect time.


From my understanding, the scheduler configuration is not part of the rule settings, so make sure you create a new scheduler "instace" when creating the rules.

photo
1

My "old" rules are working after sync. Time was correct this morning.

photo
1

Hello guys,


the issue with Time zones was resolved please check this thread

https://community.zipato.com/topic/did-you-change-timezone-or-the-clock-on-servers-all-schedules-are-wrong-one-houre


Regards