This object is in archive! 

Does rules are activate once at startup

Marcel FAGNOUL shared this question 8 years ago
Need Answer

After reading some topics in the forum, i'm not sure if the rules run one time at startup or not ?

After testing in 0,9,998 i think not, is it right or a bug ?


Thank

Replies (10)

photo
1

Since device states are reloaded after restart i see that rules are triggered.

photo
1

i'm not sure in the last firmware 0.0.0998

i will make more test.

Restart of the box need 3 to 5 min before module will be reachable . Is it normal ?

photo
1

Yep it is.

Zipabox loads its OS, establishes internet/local connecion, connect the zwave network so it takes a few minutes actually.

photo
1

i made testing

first i create a virtual sensor "alwaysonforstartup" (pic1)

then a variable "startup"

and the rule (pic2)

and nothing happen ....

photo
1

I don't know for sure..because i have not test it.


But...

Yes, states are reloaded/checked but i don't think it triggers/runs any rules.

photo
1

some strange think now, my rule get "?" when go back to the rules creator, and when i try to put back sensor and actuator, i get a warning"

i send request to support

photo
1

Marcel FAGNOUL wrote:

some strange think now, my rule get "?" when go back to the rules creator, and when i try to put back sensor and actuator, i get a warning"

i send request to support

Hi,

A month ago I had the same problem. I have made a very dirty solution in the follwing way.

1. Scheduled a rule every minute and never ending

2. In the rule,like you did I tested a variable "reboot" for a value 12345.

3. If it had not this value then i set the variable to 12345 en did additionals actions.


This works because after a reboot the value of a variable is undefined. But a solution.....

photo
1

ok John, but this use cpu power with a rule activated every minute, i would tried to activate the rules only one time.

photo
1

Marcel FAGNOUL wrote:

ok John, but this use cpu power with a rule activated every minute, i would tried to activate the rules only one time.
Marcel,


That would be the best solution. But at the moment there is no way to do so. It would be nice if there was a reboot option with the scheduler, the same as sunset/sunrise. For this moment I am not concerned about waisting cpu power, because most of the time the box is doing nothing.

photo
1

i agree with you a <reboot> condition will be the best option.

Maybe zipa team read us ;-)

Leave a Comment
 
Attach a file