No MQTT subscribes created from ZipaBox2

Kevin Hawkins shared this question 21 days ago
Need Answer

I have just purchased a ZipaBox2 (v1.3.81 firmware) having previously not had success with MQTT on ZipaTile and ZipaBox (except inbuilt sensors) . I was recently told at a trade show by Zipato that support was much better now with ZipaBox2 or ZipaTile2 for fuller integrations.

I can connect to my MQTT broker fine from ZipaBox2 and I have created some virtual devices on the ZipaBox2 but it does not then subscribe to any topics on the broker so obviously no control is possible. Why is this ? Do I have to enable these devices for control from MQTT so then subscribes are set up ?

Should these virtual devices somehow show here under MQTT as devices on MQTT ?.. created via the MQTT device auto inclusion ?

/a39a38942004196842bba878af3ad4b8

I have for example these showing here and have used the lowest device uuid

/7ccacb07f89327a9ceee7b19e7768117


I'm very familiar with MQTT but obviously the ZipaBox2 must subscribe to specific, wildcarded or even the root topic or nothing could possibly be controlled via MQTT ...


/ce0e20f2c40dcd5d7e49d04d147d5f3d

/b5298cbf2168512ac719f683cdfa5ad2

Comments (1)

photo
1

Hi,

In this topic: https://community.zipato.com/topic/mqtt-support subscription and publishing from Zipabox2 is explained (Hit show all to see the complete topic and look for the answer from Sebastian).

Zipabox listens and publishes on specific (pre-defined) MQTT topics and i don't think you can change these (not sure). So if you MQTT-device is publishing to a specific different mqtt-topic you have to redirect it in some way.

photo
1

John, thanks for the response . The publishes all work but ZipaBox2 is not subscribing to any topics. I have tried using default topics with no difference. Without a subscribe from the ZipaBox this can't work.

Are you also indirectly saying that I have to get the ZipaBox2 downgraded to 1.2.29? - Unfortunately Zipato themselves pushed the 1.3.81 upgrade to my box to fix another significant issue that made the ZiapBox2 unuseable. I am not sure 1.2.29 ever existed on a ZipaBox2.


Re 'my MQTT device' I'm just trying to control a ZipaBox virtual so I can publish to the topic that ZipaBox is subscribing to , but yes I understand I would have to redirect one of my other devices to one that ZipaBox could interact (synch) with if needed.

Kevin

photo
1

Hi Kevin,

Tried to answer you, but something is wrong. Two times my answer was lost. Next try: If you can't subscribe to any topic then something is broken in your release. I am on 1.3.66 and ZP2 subscribes any attribute automatically. I use this topic in my raspberry with openhab.

photo
1

Ahh John - that's good that I know you are on ZipaBox2 and 1.3.66 - and it's working, I'm more hopeful now . I am going to try totally defaulting the broker configuration details again removing all custom info inc. topics and user/password. Could you perhaps post yours (redacting anything as needed) .. here's mine.. or I can post an email address for me - seems you can't PM on here

{

"link": "networks/3d76e253-b3ba-4935-a2c0-58e8a3114ec7",

"config": {

"className": "com.zipato.network.mqtt.MqttNetwork",

"password": "redacted",

"clientId": "zipabox2",

"qos": 2,

"topicPrefix": "zipabox2/",

"name": "MQTT",

"broker": "tcp://192.168.1.22:1883",

"uuid": "3d76e253-b3ba-4935-a2c0-58e8a3114ec7",

"topicBase": "zipato/",

"username": "kevin",

"tags": null,

"order": null

},

"icon": null,

"showIcon": null,

"templateId": null,

"userIcon": null,

"uuid": "3d76e253-b3ba-4935-a2c0-58e8a3114ec7"

}

photo
1

Hi,


Dinner is ready. No time left. Changed user and password:

{

"link": "networks/4db940a8-6751-4e4e-bfd6-eb03b10701b3",

"config": {

"className": "com.zipato.network.mqtt.MqttNetwork",

"password": "xxxxxxxxx",

"clientId": "zipato",

"qos": null,

"topicPrefix": null,

"name": "MQTT",

"broker": "tcp://192.168.2.111:1883",

"uuid": "4db940a8-6751-4e4e-bfd6-eb03b10701b3",

"topicBase": null,

"username": "aaaaa",

"tags": null,

"order": null

},

"icon": null,

"showIcon": null,

"templateId": null,

"userIcon": null,

"uuid": "4db940a8-6751-4e4e-bfd6-eb03b10701b3"

}

photo
1

Thanks John but still not working... I'll keep at it - aside from username/password and uuid/ip my config exactly matches yours.

There are still no subscribes created by the ZipaBox.

Just for absolute clarity you are able to control virtual devices (and real devices) on your ZipaBox from openHAB - not just see the status of the devices in openHAB.

photo
1

Kevin,

Yes. On my ZP2 box i have: virtual, Zigbee, Zwave and 433 Mhz. I can control all these devices from openhab via mqtt. Most of these devices are just on/off things. But they are working. The only thing that I haven't tried are my Somfy rts screens. These screens are positioned by value = 0-100% value. But I don't see why that should not work. But you never know..

photo
1

Kevin,

1 last thing: Zipabox published the state of a switch as true and false. To set such a switch you must have true or false in your payload. In my case Openhab uses for switches ON/OFF and for contects OPEN/CLOSED. That means you have to transform the values to the right thing OPEN->true and CLOSED->false.

photo
1

I can do the transforms - or I can map the topics/payloads using NodeRED. I'd like to be at that stage but I just can't get the ZipaBox2 to subscribe to any topic so it is effectively deaf. It publishes device state fine. I have a lot of controllers and devices already interacting via MQTT, it's becoming the basis of my system as I have a lot of different systems.

The Bevywise MQTT broker Route app shows there are no subscribes in place so until I sort that I'm stuck. I'm going to see if it needs some particular type of 'real' device created on ZB2 in order to start subscribing ....I believe it uses a near root level topic for the subs.

I'm slightly concerned it's a firmware issue but don't want to downgrade just yet.

One other Q. When you click on 'Add new device' and get the network browser and select MQTT and click it - what happens . I get an MQTT hierarchical menu with my controller serial number below. With a 'Select controller bellow' (sic) message, and when I click on my controller it moves to a never ending ' Step 2 Joining Device' 'Starting device inclusion; spinning circle. I have no idea what this is used for or is supposed to be doing but it never ends. Do you know what it's purpose is ?

photo
1

Don't downgrade but submit a ticket and let Zipato look into it.

Concerning your last question: I have the same. I think that the MQTT inplementation is unfinished. The ZP2 subscribes any attribute to a predefined topic. You can't change that. I hope when they finished the MQTT implementation there will be a possibility to change that predefined topic.

photo
1

/2d959e066a97fffb7c55ccdcaa4e7d0aGood day Kevin.

Do you understand that the publication and subscription branches are different?

photo
1

in the branch "textValue" you can publish "1 or 0", and not "true / falce".

photo
1

Hi Dmitry - yes I have tried a few variants for the subscription topic (with ../request/.. within the topic) and also both payload versions (text and json) with ../textValue and ../value respectively. The Bevywise MQTTRoute broker is showing their are no subscriptions ever created though. See below

I assume that screenshot above is from some other MQTT client software ??

photo
1

Here you will see the log of the broker


Bevywise MQTTRoute - Trial Version - expires on Fri Nov 29 20:22:27 2019
TCP Port - 1883 WebSocket Port - 10443
View your connected devices via your browser at - <a href="<a href="<a href="http://localhost:8080">http://localhost:8080</a>">http://localhost:8080">http://localhost:8080</a></a>">http://localhost:8080">http://localhost:8080</a>">http://localhost:8080">http://localhost:8080</a></a></a>;;;
Authentication Enabled
[MQTTROUTE]04-11-2019 16:20:00 - Client No:1 New connection request from 192.168.1.22 clientid is mqtt-explorer-60a85203
[MQTTROUTE]04-11-2019 16:20:00 - mqtt-explorer-60a85203 subscribed to #
[MQTTROUTE]04-11-2019 16:20:00 - mqtt-explorer-60a85203 subscribed to $SYS/#
[MQTTROUTE]04-11-2019 16:27:04 - Client No:2 New connection request from 192.168.1.216 clientid is ZB1974xxxxxx5611FB

You see my client (MQTT Explorer) logging on and creating two subscriptions and then Zipato logging on but it never creates any subscriptions. It is publishing updates to MQTT for its devices fine.

photo
1

/28239d5230308587f53d782b20a7fdb6

I have Zipatile 1, with the settings as in the screenshot. After changing the settings via api, be sure to click - save and synchronize! Maybe try rebooting.

photo
1

aside from the username/password mine are the same.

What firmware version are you on ? There isn't one on the API page.


I have a ZipaBox - I will try that too if I have the same firmware version as you


I have always done the synch and fully rebooted my ZipaBox2 and it comes up with any API changes in place so they have been updated.


The 'save' button you refer to is where ?


Is it this one ?

/63712776fb7fe9df63ac94dbc336dc01

photo
1

So I tried this on my original zipabox on v1.3.6 firmware and I got this


 

[MQTTROUTE]04-11-2019 21:03:51 - Client No:1 New connection request from 192.168.1.232 clientid is 010137xxxxxxF556
[MQTTROUTE]04-11-2019 21:03:52 - 010137xxxxxxF556 subscribed to /010137xxxxxxF556/request/#


Which is as I would expect . So I now think firmware v.1.3.81 may have broken MQTT , or my ZipaBox2 is otherwise messed up.

photo
1

/9d7bd246b9d590db6be7b28b3e50d986

/899e1e0b84ada822aaa34642b08f20aa

photo
1

/3addaa0718176a125b02ea79a3fe3fa6

/af9edb5f59cdad2bb6745c52eb534a51

Hi Kevin. You say that your settings do not differ from mine, but this is not so!

I do not claim that this will help, but maybe yes.))

photo
1

Dmitry - What I meant was 'now' as I since altered them all to be identical a few days back.Originally I had topics setup but now at null. My broker requires username/password.

For QOS I have tried both 0 , null and 2 (the latter being what Sebastian posted).

I have this working on my ZipaBox (v1.3.61) - just not my ZipaBox2 (v1.3.81)

I am occasionally seeing this in the broker log for the ZipaBox2 after the connection. No subscribes though


Error in ZB1974xxxxxxxx11FB disconnecting.

WARNING:websocket_server.websocket_server:Client must always be masked.

photo