KNX device: bytes values unsupported (temperature, date, time, brightness, windspeed...)

Alain Giller shared this problem 4 years ago
Known

Zipabox cannot read correctly bytes value, it's interpreted as boolean. So there is currenty no possiblity to read those values from the knx bus. It's a pitty, I've a KNX weather station and I can't see the different values

Comments (28)

photo
1

Hi,


you need to make sure you posses a Zipabox KNX expansion module.

If you do please contact us on support@zipato.com


Kind regards,


Hrvoje

photo
1

I have the KNX module... switch works fine. For blinds there is also some bugs.

photo
1

Please contact us on support@zipato.com with your user credentials


Best regards,


Hrvoje

photo
1

I have the same problem. I would like read the temperature value or execute KNX scene !

Only Bit value can be read or write ?

photo
1

Up !

photo
1

Nothing new,they are hopefully working on it. I posted a bug report the 10 september 2014( #JVM-156-52852)

photo
1

Nothing new on the last update, bytes values still unsupported, it's a pitty...

photo
1

I affraid it is still unsupported...

photo
1

Blinds read correct Status over KNXIP but could not be controlled.


So the same Problem there.

photo
1

Now since 2 years there no updates. I contact the support but nothing append.

photo
1

Actually, it works for me until and including V1.0.17. (If you have a sw version above that those it will not work.)


When adding devices you tell what data type it has and then the Zipabox displays correctly in my setup. (Windspeed, temperature, brightness is what I use.)

photo
1

Very interesting, can you please attach an ETS printscreen? I've attached my config, if you see something wrong... Thanks!

photo
1

Hello,

I'm running V1.3.29 and facing the same problem, impossible to read values.

Any updates on it?

Thanks!

photo
1

For some time it works fine for me . Again, you have to set it on the KNX side in a way that the values are actually being sent. (as a start try to select all flags in your ets software for the given device)

I am currently on Zipabox sw V1.3.13

photo
1

Hi RoSche,

Thank you for your feedback...

Could you please explain more?

If you could add some screenshots, I will appreciate a lot!

Thank you!

photo
1

Hi Speedman1260,

find attached 2 screen captures that show the flag settings that I have in my ETS software. As you can see the Send and receive flags are the other way around that one would expect. Not sure if this is only for me or if the ETS has a different logic.

As you will see I have also the BAOS figures still in, although I dont use that anymore since I migrated to KNXIP.

Does it help?

photo
1

Thank for the update... I think its normal, as I see for the flags, because you read it from Weather Station and write it to KNX BAOS to push to Zipato.

Also, what "KNXIP devices" are you using (Meter, Multivalue or Value??) and what do you put in Value Datapoint Type in Zipato?

Btw, I've asked the same question in another thread... (KNX interface to ip)

It seems lot of people have troubles with KNX and Zipato integration.

I have a lot of sensors that I want to monitor and react from Zipato (swimming pool temperature, pH, temperature all around house, water counters), so I really hope to make it work ....

Thank you!

photo
1

I think I got most things wortking between KNX and Zipato. In fact this is the one thing for me that makes the Zipato pain worthwhile to endure. :-)

On the data points:

I manually create the control file (via Excel and a little script since I dont have a new ETS version that Zipato can read) and for the 3 luminance values as shown before it has those entries:

{

"groupName" : "Helligkeit West",

"dptId" : "9.004",

"num" : 129,

"group" : "4/1/8"

}, {

"groupName" : "Helligkeit Süd",

"dptId" : "9.004",

"num" : 130,

"group" : "4/1/9"

}, {

"groupName" : "Helligkeit Nord",

"dptId" : "9.004",

"num" : 131,

"group" : "4/1/10"

}

When creating the data points I can choose the group from the drop downs but have to re-enter the datapoint type (in this case 9.004) manually.


Also, I have a separate group for each meter (Can't remember if I did it because it did not work for multiple meters in one group for KNX devices), you might want to test it first with a single meter too.

photo
1

RoSche, thank you for your reply...

So I downgraded to 1.3.13, and same result.

The only difference i see, that i have multiple meters in one group. It's sad, that it's impossible to get some debug logs from Zipato.

But i'm 700 km from the house, and the KNX interface is locked on the Zipato connection (getting "the interface cannot accept the new data connection"). So I will have to go on place latter to reset it in order to modify the ETS configuration.

Still hope to get some official help from Zipato too...

Thank you!

photo
1

RoSche.. I spent 10 hours again.. and no result.. :-(


Could you please explain, what do you mean my a separate group?


Thank you!

photo
1

OMG. Sorry to hear that.


1) on "separate group": I meant that I created a individual meter in Zipato for each KNX meter, instead of having multiple values included in a Zipato meter with several "sub-meters".

2) How do you import the KNX group addresses into Zipato? Could it be that there is an error?

3) Did you set the flags correctly on the KNX side to make sure that the meter values are readable (as I was showing in my screen shot earlier)?

Cheers

photo
1

Thanks for your fast reply RoSche,

1) Ok, i did the same

2) I use ESF file export from ETS, and it worked for blinds.

3) Yes, I checked my flags .. :(

Now, this is very strange.. it's just showed me a swimming pool temperature after closing the project in ETS.

I did a connection test on both interfaces (Im using 730 and 731 Weinzierl interfaces... ) from ETS.. and it shown me on a multimeter...

Really don't understand whats going on... Zipato team.. HELP!!!

Cheers

photo
photo
1

I forgot to add, I use KNXIP, and not a Zipato KNX extension module.

And blinds are working perfectly, the status of position and setting of % is working great.

Thank you!

photo
1

On the blinds: I also get now the status flags in my Zipabox (I use normal "switches" in Zipabox) , but not the % settings. I assumed that is because my KNX devices dont use the %. I tried different assignments of my KNX groups but it never worked as blinds.

What settings did you use? I only have long and short press on the KNX side. Do you have more?

photo
1

For the blinds, I use KNXIP blinds module. I'm able to slide to setup % of opening, and if I change it from KNX, it updates it correctly to Zipato.

I don't use slats, so i don't need short press. Also, I've had to migrate my KNX old Hager TS223 / TS224 modules to Hager TXA223 with TXA223 - a2 program to get the position % reporting.

photo
photo
1

FYI: For IP connectivity to The KNX bus I am using an old SIEMENS interface. There isn’t anything that I can configure on this device.  Can’t say if this could play a role. 

FYI2: I read several luminance and several temperature meters as well as wind speed from my KNX bus to use on the Zipabox side. Beside there are several 0/1 values that I use in a similar way (eg certain wind speed thresholds or alarm flags). 

For the past ca 2 years or so that works fine for me. 

If the Zipato team is not able to help in time I would try a manually created import file just to exclude that as an error source. 

And yes, I also wish there would be something that can be called Zipabox documentation not to waste so much time in trial and error by so many community members like you and me that actually should be a value to that company to create new valuable stuff and spread the gospel. :-(

Am 08.09.2018 um 17:50 schrieb Zipato Support Portal <mailer@3plus.hr>:

photo
1

RoSche, goof news!

In fact i was supposing that Zipato was polling the device... but it just read it from network.

So, when I was reading the datapoint from ETS, it was sending, Zipato was able to read it.

I've change the setup on the device to broadcast the value on the network, and it works now ! (of course, only Meter, not MultiValue or Value..)

Thank you!

photo
photo
1

Super – congrats!

You are indeed right, I was wrongly assuming that the Zipabox software by now automatically polls data from the KNX bus instead it is just waiting for a KNX data send to be read. In my system I also made the KNX devices send the meter data proactively every x minutes. (@ Zipato team: a product documentation is a helpful thing and there are reasons why other companies create such things. )

So for everybody else being on software V 1.3.13 or lower it means:

- KNX meters can be read via Zipabox but only if proactively send by the KNX device. The Zipabox does NOT pull meter data from the KNX bus, it does not initiate a read command as of now.

- MultiValue setups are likely not working either, at least I have not been able to get they up and running. However that - at least for me - is a minor issue.

Von: Zipato Support Portal <mailer@3plus.hr>

Gesendet: Samstag, 8. September 2018 23:40

An: RoSche <robertoschettler@yahoo.de>

Betreff: New Comment in "KNX device: bytes values unsupported (temperature, date, time, brightness, windspeed...)"